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Introduction
JigSoft is an innovative game that lets you put jigsaw puzzles together on your computer. JigSoft provides you with many 
different skill levels and literally millions of different ways to carve up a puzzle picture. JigSoft is perfect entertainment for 
both adults and children.

Technical Support
Thank you for purchasing this software program from Eclectek, Inc. All efforts have been made to provide you with an 
easy–to–use application and clearly written, well–organized documentation. If you do encounter any difficulty using this 
program, we maintain a customer service/technical support staff who will gladly provide assistance and answer any 
questions that might arise.
When you call for technical support, please be ready with the following information: the name and version of the program, 
and a general description of your computer equipment and operating system. We will also need to know the serial number
which appears in the About box (under the Help menu). You should be at your computer and have the program running 
when you call, so you can describe exactly what the problem is and follow the instructions or suggestions our support staff
will provide.
Our customer service/technical support department is staffed Monday through Friday from 9:00 a.m. to 5:00 p.m. Pacific 
Standard Time (excluding major holidays). Here’s how to reach us:

By phone – (503) 344–9792
By fax – (503) 343–8442

Compuserve – 76330,3344
Internet – eclectek@ortel.com



Chapter 1—Quick–Start
When you start JigSoft, you will see the initial puzzle picture and the default puzzle cut for Novice level. The Skill menu 
allows you to choose from Novice, Intermediate, and Expert skill levels.

Tool Palette
In the upper right corner of the screen, you will see the JigSoft tool palette. The tools in this palette offer shortcuts for 
several options which will make puzzle–solving easier.
 The icon in the top left corner is a green light, signalling “GO.” Clicking this icon will start a puzzle session: JigSoft will cut 
the puzzle, spread out the pieces, and start the clock. Clicking this icon will also resume a paused puzzle session.
Clicking this icon is equivalent to choosing Start Puzzle Session (under the Puzzle menu).
 The icon in the top right corner is a red light, signalling “STOP.” Clicking this icon will stop the current puzzle session. You 
should use this icon only if you want to end a puzzle session permanently. You will be given the option of saving the 
puzzle session if you haven’t already.
Clicking this icon is equivalent to choosing Stop Puzzle Session (under the Puzzle menu).
 The left–hand icon in the second row is a hand, signalling “PAUSE.” Clicking this icon will stop the clock, and you will not 
be able to drag any more pieces until you click the green light to resume the puzzle session.
Clicking this icon is equivalent to choosing Pause Puzzle Session (under the Puzzle menu).
 The right–hand icon in the second row is the solve mode icon. This mode will solve the puzzle one piece at a time. 
Clicking this icon will change the cursor to a question mark. Position the cursor (the starting point—the top left tip—of the 
question mark (?) is the hot spot) over the piece you want solved and click the left mouse button. The piece you clicked 
will move to its correct location in the Main Area. You may solve as many pieces as you like simply by clicking them. To 
return to regular mode, click the solve mode icon again and your cursor will revert to an arrow.
 The left–hand icon in the third row is the zoom mode icon. Clicking this icon will change the cursor to a magnifying glass. 
Position the cursor (the center of the plus sign (+) is the hot spot) over the spot you want to magnify, and click the left 
mouse button. The spot you clicked will be positioned in the middle of the screen. You can continue to zoom in by 
repeatedly clicking the left mouse button, or zoom out by clicking the right mouse button.
When you’re done looking at a piece in detail, click the zoom icon again to return to normal view. Your cursor will revert to 
an arrow. You cannot assemble or finish the puzzle in zoom mode.
Clicking this icon is equivalent to choosing Zoom (under the View menu).
 The right–hand icon in the third row is the scatter button. Clicking this icon will scatter any unsolved puzzle pieces away 
from the inside of the puzzle frame in the Main Area (where your puzzle is completed).
The scatter button is especially helpful at the beginning of a puzzle session to clear out the inside of the frame so you can 
place pieces in it without getting distracted. It is also handy to uncover pieces that may have been covered up by other 
pieces.
There are two settings for the scatter button which can be changed in the Preferences dialog (under the Options menu): 
normal scatter and wide scatter.
Normal Scatter: Scatters pieces to the areas closely surrounding the Main Area. Pieces will tend to pile up on one another
and overlap.
Wide Scatter: Scatters pieces throughout the entire puzzle desktop. This option is helpful if you don’t want as many pieces
to pile up on top of each other during a scatter. However, this setting will require you to scroll around the screen more 
often in search of pieces.
Clicking this icon is equivalent to choosing Scatter (under the View menu).
 The icon in the lower left corner is the organize icon. This icon allows you to quickly switch between JigSoft’s four 
organizational modes, which are designed to help you move and manage pieces between the three separate work areas 
available on the JigSoft desktop. 
The work area feature can help you organize different types of pieces quickly into different areas, much like you would if 
you were putting a jigsaw puzzle together on a tabletop.
The different modes are: regular mode, Organize to Work Area 1, Organize to Work Area 2, and Organize Back to Main 
Area. To switch modes, just click a different part of the organize icon. You must be in regular mode to finish a puzzle.
Regular mode, represented by the upper left arrow icon, lets you drag pieces anywhere on the desktop. This is the mode 
you must be in to actually connect pieces together and complete the puzzle. When you click this portion of the organize 
icon, the cursor will change to an arrow.
The second mode, represented by the “1” in the upper right corner of the icon, lets you send pieces to Work Area 1, the 
first of two special work areas available to you. When you click this portion of the organize icon, the cursor will change to a
“1.” When you click a piece in this mode, it will automatically be moved into Work Area 1.
The third mode, represented by the “2” in the lower left corner of the icon, lets you send pieces to Work Area 2, the 
second of two special work areas available to you. When you click this portion of the organize icon, the cursor will change 
to a “2.”



The fourth mode, represented by the “M” in the lower right corner of the icon, lets you send pieces from anywhere on the 
screen–including any pieces in the two work areas–back into the Main Area. When you click this portion of the organize 
icon, the cursor will change to an “M.”
 The icon in the lower right corner is the Quick Scroll icon. It allows you to quickly flip between the four main areas on the 
puzzle screen. These areas can also be seen by using the scroll bars at the right and bottom of the screen. These four 
areas are:
1. The main puzzle frame (also referred to as Main Area). This is where you complete the puzzle.
2. Work Area 1. Located to the right of the Main Area, this space can be used to organize specific 

portions of the puzzle before moving them back to the main area.
3. Work Area 2. Located below the Main Area, this space has the same purpose as Work Area 1.
4. Overview Area. Located below Work Area 1, and to the right of Work Area 2, this area will show an

overview of what the completed puzzle should look like. This is similar to looking at the box top of an 
ordinary jigsaw puzzle. This area will be blank if the Overview Window option (under the View menu) 
is disabled.

Changing the Colors of the Desktop
To help you view and assemble puzzle pieces more easily, JigSoft lets you change the colors of the desktop and the work 
areas. Choose the Colors option (under the Preferences menu) to see a dialog of the available colors. Click the diamond 
next to the color you want, then click OK.
You can also scroll through the available colors by holding down the Shift key and clicking the left mouse button to change
the colors exterior to the puzzle frame and work areas, or holding down the Shift key and clicking the right mouse button 
to change the color of the interior of the puzzle frame and work areas.

Put Together a Simple Puzzle
1. To start your first puzzle, simply click the green light. JigSoft will scatter the pieces and start the 

clock.
If the skill level is set to Intermediate or Expert, some of the pieces may be flipped (mirror image). 
Click the right mouse button on a piece to flip it. Puzzle pieces must be flipped to their correct 
orientation before they can be connected to other pieces or placed in the Main Area.

2. Position the mouse over the piece you want to move. Hold down the left mouse button, drag the piece 
where you want it, then release the mouse button. If you happen to position the piece in its correct 
location (in the Main Area or connecting to another piece), you will hear a “beep” and the piece will 
snap into place.
Both the tool palette and the help bar will disappear while you’re dragging a puzzle piece and will 
reappear when you release the mouse button. This is done to optimize performance of dragging as 
much as possible.

3. Continue moving pieces into position until you’ve completed the puzzle. Most pieces will initially be 
scattered within the visible area of the screen; use the Quick Scroll icon or the scroll bars to scroll the
puzzle desktop to find more pieces, if necessary. You may also want to use the extra area of the puzzle
desktop to temporarily get pieces out of the way so that you can work more easily within the Main 
Area. Use the Scatter icon or one of the Organize Modes.
Puzzle pieces can overlap, sometimes completely obscuring each other. This often happens within the 
Main Area itself. If you get close to finishing the puzzle and can’t find any more pieces, it’s possible 
that you have covered one up in putting the puzzle together. Don’t worry—all you have to do is click 
the Scatter icon, or choose Scatter (under the View menu). If a non–connected piece is lying 
underneath the puzzle, it will be scattered outside the frame.
You can also find a hidden puzzle piece by clicking within the puzzle frame until you hit the hidden 
piece. It will then be brought on top of the other pieces and you may drag it to another location.
When you have completed the puzzle, the clock will stop and the green light will come back on.

Loading a New Puzzle Picture    (NOT AVAILABLE IN DEMO 
VERSION)
You should never run out of Puzzle Pictures with JigSoft. Besides allowing you to paste any bitmap from the clipboard, 
JigSoft can also import bitmaps in a variety of other formats. These include:



Windows Bitmap (BMP) Truevision Targa (TGA)
Tag Image File Format (TIFF) PC Paintbrush (PCX)
Joint Photo Experts Group (JPEG)Quickdraw PICT (PCT)
WordPerfect Graphics (WPG) Graphic Interchange Format (GIF)

To import a picture from a file, select Import Picture from File (under the Puzzle menu). This will bring up the Open Bitmap 
dialog box. You can choose from a variety of bitmap types shown in the “Type” list box.
JigSoft automatically sets up two subdirectories under the “Pictures” directory. These subdirectories are “16COLOR” and 
“256COLOR.” 
If your current video driver is in 16 color mode, choose a picture out of the “16COLOR” subdirectory. Although you can 
choose a picture from one of the other subdirectories, it is likely that the colors will be distorted when you load a picture.
If possible, we recommend running JigSoft in 256 color or better mode. This will provide you with the best quality images 
to work with. If your current video driver is in 256 color mode, you can choose a picture from either the “256COLOR” 
subdirectory or “16COLOR” subdirectory.
If your current video driver is in 32K color, 16 million color or another “true color” mode, you can choose a picture from 
either subdirectory. In general, the higher number of colors, the more realistic the image.

Note: To determine the mode of your current video driver, go to the Program Manager in Windows. 
Double click on the Main program group icon, then double click on the “Windows Setup” in the 
“Main” window. The first item in the “Windows Setup” window is the display mode. In most cases, a 
VGA display is an indicator of a 16 color video driver. Most 256 color display or higher drivers will 
indicate the number of colors available.
Caution: Do not attempt to change your video driver. You can only use a video driver which 
is compatible with your computer’s video card. See your computer dealer regarding this.

Once you have selected the file you want to import, click OK and the picture will appear inside the puzzle frame.
You can also import a picture from the clipboard by using the Paste Picture from Clipboard option (under the Puzzle 
menu). This option works only if you have a valid bitmap image in the clipboard.

Note: You can also change your puzzle picture in the middle of a session.



Chapter 2—Work Areas
When putting together a complicated jigsaw puzzle on a tabletop, most people like to organize the puzzle pieces to make 
puzzle solving easier. JigSoft includes a work areas feature that allows you to organize your pieces on the computer 
screen.
To understand how work areas can help you, load in a puzzle image you want to work with. Start your puzzle session by 
clicking the green light icon on the tool palette or by choosing Start Puzzle Session (under the Puzzle menu). Next, click 
the scatter icon on the tool palette or choose Scatter (under the View menu). This will clear the puzzle pieces away from 
the Main Area.
Now you need to decide how you want to organize your puzzle pieces. Three work areas are provided: Main, 1, and 2. 
Most people like to start putting a puzzle together by assembling the border pieces. Use your cursor to drag pieces with 
straight edges into the Main Area. (Since the normal scatter option stacks some pieces on top of others, you will probably 
not be able to find all of the border pieces at first. Be sure to use both the horizontal and vertical scroll bars to find all of 
the pieces.)
There are two additional work areas into which you can move pieces. Decide which pieces you want to group together (by
color or subject matter). Click the “1” in the upper right corner of the organize icon on the tool palette or choose Organize 
to Work Area 1 (under the Organize menu). Your cursor will change to a “1” and each piece you click will be sent to Work 
Area 1. Move a different category of pieces to Work Area 2. Click the “2” in the lower left corner of the organize icon or 
choose Organize to Work Area 2 (under the Organize menu). Your cursor will change to a “2” and each piece you click will
be sent to Work Area 2.
Assemble the border pieces in the Main Area. When the border is complete, move to Work Area 1 and assemble another 
portion of the puzzle, or click the “M” in the lower right corner of the organize icon and send each of the pieces in Work 
Area 1 back to the Main Area.
Assemble the pieces you sent to Work Area 2 as described above. If there are additional pieces to be organized to 
complete the puzzle, move those pieces to Work Area 1 or 2 and continue until the puzzle is completely solved.

Note: Puzzles can be completed (finished) only in the Main Area. Puzzle pieces must be flipped to 
their correct orientation before they can be connected to other pieces or placed in the Main Area.



Chapter 3—Menu Reference

The File Menu

Open Existing Session Ctrl+O    (NOT AVAILABLE IN DEMO VERSION)
This option allows you to load in an existing puzzle session from disk so that you can continue to work on a puzzle that 
was saved earlier. To save a partially completed puzzle, see Save Session.

Load Cut Ctrl+L
This option allows you to load a stored puzzle cut from disk. This cut can be one that was originally supplied with JigSoft, 
or one that you created yourself through the User Carved option (under the Skill menu).
One of the unique features of JigSoft is its ability to provide an endless supply of piece shapes. Through the User Carved 
option, you can create and save as many different puzzle cuts as you like. This is a great way to make unique puzzles that
both beginners and experts can enjoy.

Save Session Ctrl+S    (NOT AVAILABLE IN DEMO VERSION)
This option allows you to save the current puzzle session. This lets you store a partially–completed puzzle to finish at a 
later time.

Save Cut Ctrl+C
This option allows you to save a cut that you have just made using the Skill Menu’s “User Carved” option. The standard 
file extension for custom puzzle cuts is “.CUT.”

Exit Alt+F4
This option closes JigSoft. You will be given the option of saving the current puzzle session if you haven’t already.

The Puzzle Menu

Import Picture from File    (NOT AVAILABLE IN DEMO VERSION)
This option brings up the Open Bitmap dialog box for you to select a bitmap to import. You can choose from a variety of 
bitmap types in the “Type” list box. Once you have selected the file you want to import, click OK and the picture will 
appear inside the puzzle frame.

Note: You can also change your puzzle picture in the middle of a session.

Paste Picture from Clipboard    (NOT AVAILABLE IN DEMO VERSION)
This option allows you to paste any valid bitmap or Device Independent Bitmap (DIB) stored in the clipboard into your 
puzzle frame for use by JigSoft. If there is no valid image in the clipboard, this menu option will be grayed (unavailable).

Show Clipboard
This option displays the current contents of the clipboard.

Start Puzzle Session
This option starts a puzzle session. JigSoft will cut the puzzle, spread out the pieces, and start the clock. This option is 
equivalent to clicking the green light icon on the tool palette. This option will also resume a paused puzzle session.
Select this option after you have chosen the puzzle picture you want to use (see Import Picture from File or Paste Picture 
from Clipboard) and the skill level (see the Skill menu).

Pause Puzzle Session
This option pauses a puzzle session. JigSoft will stop the clock and will not allow you to drag any more pieces until you 
start the puzzle again by either clicking the green light icon or choosing Start Puzzle (under the Puzzle menu). This option 
is equivalent to clicking the pause icon on the tool palette.



Stop Puzzle Session
This option will stop the current puzzle session. You should choose this option only if you want to end a session 
permanently. You will be given the option of saving the current puzzle session if you haven’t already. This option is 
equivalent to clicking the red light icon on the tool palette.

Auto Solve
This option tells JigSoft to automatically solve the entire puzzle for you. This is different from using the tool palette’s solve 
mode button, which allows you to have JigSoft solve for only specific pieces that you click.

The Skill Menu

Novice Ctrl+N
This option sets the skill level to Novice. The Novice skill level is originally set by JigSoft to be a 12–piece puzzle, with a 
pixel snap of 8 and none of the pieces flipped. You can change this definition of Novice through the Customize Skill Level 
option (under the Options menu).

Note: You can flip a puzzle piece upside down (mirror image) by clicking the right mouse button on 
the piece. Puzzle pieces must be flipped to their correct orientation before they can be connected to 
other pieces or placed in the Main Area.

Intermediate Ctrl+I
This option sets the skill level to Intermediate. The Intermediate skill level is originally set by JigSoft to be a 48–piece 
puzzle, with a pixel snap of 6 and the puzzle pieces randomly flipped upside down (mirror image). You can change this 
definition of Intermediate through the Customize Skill Level option (under the Options menu).

Note: You can flip a piece upside down (mirror image) by clicking the right mouse button. Puzzle 
pieces must be flipped to their correct orientation before they can be connected to other pieces or 
placed in the Main Area.

Expert Ctrl+E
This option sets the puzzle to the Expert Skill Level. The Expert skill level is originally set by JigSoft to be a 192–piece 
puzzle, with a pixel snap of 4 and the puzzle pieces randomly flipped upside down (mirror image). You can change this 
definition of Expert through the Customize Skill Level option (under the Options menu).

Note: You can flip a piece upside down (mirror image) by clicking the right mouse button. Puzzle 
pieces must be flipped to their correct orientation before they can be connected to other pieces or 
placed in the Main Area.

User Carved Ctrl+U

This option allows you to create your own puzzle cut. This is an advanced feature which requires you to understand a little
bit about how JigSoft creates puzzles. Please read the following carefully to get the best results from creating your own 
puzzle cuts.
A puzzle is made up of columns of pieces and rows of pieces. Each column has the same number (the number or rows) of
pieces. Each row has the same number (the number of columns) of pieces. For example, the Novice puzzle has 4 
columns and 3 rows. Each column has 3 pieces, each row 4 pieces, for a total of 12 pieces.
When you choose the User Carved option, the User Carved dialog will appear. This dialog allows you to change the the 
number of rows and columns you want in your puzzle. The minimum value you can set for either is 2. The maximum you 
can set for rows is 12, the maximum for columns is 14. The number of pieces you end up creating can be calculated by 
multiplying the two numbers. For example, if you select 3 rows and 5 columns, this will create a 15 piece puzzle (3 x 5).
Click OK when you’re done setting the options. A rectangle representing the puzzle area will appear on the screen.
Small squares will appear above the top border and along the left border of the puzzle area. These squares indicate the 
number of lines to be drawn. The leftmost top rectangle will be green, the rest will be white. The column lines are drawn 
starting with the leftmost column line, indicated by the green rectangle. After the column lines are finished, the row lines 
are drawn starting at the topmost row line.
Cut the puzzle by dragging the mouse to draw column and row lines. (Your cursor will change to a knife.) The number of 
column lines that need to be drawn is one less than the number of columns. The number of row lines that need to be 
drawn is one less than the number of rows.



Here are the rules to be followed when drawing lines:

RULE 1: Each column line starts at the upper border and ends at the lower border. Each row line 
starts at the left border and ends at the right border.

RULE 2: A column line should not cross itself or any other column line.
RULE 3: A row line should not cross itself or any other row line.
RULE 4: A row line should cross each column line once and only once.
RULE 5: A line should not retrace itself or duplicate segments of other lines. That is, a line should not 

have duplicate points and should not duplicate points of another line, except for the points 
where a row line crosses a column line. These crossings should have only one point in 
common.

All the rules above should be followed to make exact pieces. However, except for rule 1, they need not be followed to 
make usable puzzle pieces. Some unusual pieces can be drawn by ignoring the rules. If the rules are not followed, pieces 
may have extraneous lines or parts, but can be moved and placed in the puzzle. If a puzzle cannot be made from the lines
you draw, an error message will appear. Click OK to try again.
When you start drawing a line, the appropriate rectangle will be green. When the line is finished, the rectangle will turn 
red. To draw a line, move the cursor a little above the top border (for a column) or a little to the left of the left border (for a 
row), then hold down the left mouse button and drag to draw the line. Notice that the cursor changes to a knife while 
you’re drawing. When the cursor reaches or goes beyond the opposite border, release the button. If the line you drew is 
valid, the rectangle will turn red. Draw the next line.
If you make a mistake or don’t like the lines you drew, you can erase them and try again. Erase a line by positioning the 
cursor in the square for that line and clicking the right mouse button. All lines that were drawn after the line you erase will 
also be erased.
When you have finished drawing the lines for a puzzle, the Save Cut dialog box will appear. If you want to save the cut 
you’ve just made, type in a filename, or click the filename of a cut you want to overwrite, then click OK. If you don’t want to
save the cut, click Cancel. You can now start the puzzle by clicking the green light or choosing Start Puzzle Session 
(under the Puzzle menu).

The View Menu

Show Picture Ctrl+G
This option changes the view of the puzzle frame to show only the current puzzle picture.

Show Cut Ctrl+H
This option changes the view of the puzzle frame to show only the current puzzle cut with no picture.

Show Both Ctrl+B
This option changes the view of the puzzle frame to show both the current puzzle picture and the current puzzle cut.

Tool Bar
This menu option toggles the tool palette on and off. By default, the tool palette is visible.

Note: Both the tool palette and the help bar will disappear while dragging a puzzle piece and 
reappear when you let up on the mouse button. This is done to optimize performance of dragging as 
much as possible.

Overview Window
This option toggles the Overview window on and off. By default, the Overview window is enabled.
This Overview window will show an overview of what the completed puzzle should look like. This is similar to looking at 
the box top of an ordinary jigsaw puzzle.
The Overview window is initially located in the bottom right portion of the puzzle desktop. This position is called Standard 
Placement and can be changed in the Preferences dialog (under the Options menu). You can get to this portion of the 
desktop quickly by using the Quick Scroll icon on the tool palette or the scroll bars. The Overview window area will be 
blank if this option is disabled.



In Standard Placement mode, the Overview window’s size defaults to the same size as the Main Area. You can change 
this in the Overview Size dialog (under the Options menu). If you want to reposition the Overview window, you can do so 
only while a puzzle session is “paused.”
If you are in the middle of a puzzle session, you can turn the window off but you cannot turn it back on again during the 
current session. This is due to the fact that the Overview window is a separately maintained bitmap and is deleted to 
conserve memory when the Overview window is disabled. The Overview window can be generated only before you start a
puzzle session.
If you don’t need the Overview window and would rather use this space for assembling pieces, you will want to disable 
this option.
You can also specify a custom mode for the Overview window in the Preferences dialog. In this mode, the Overview 
window will appear near the Main Area of the puzzle desktop in a sizeable, moveable window.

Note: You must size the window before you start a puzzle session. You should position the window 
before you start a puzzle session. Once a puzzle session has started, you can move the Overview 
window only while a puzzle session is “paused.”

Help Bar
This option toggles the context sensitive help bar (along the bottom of the screen) on and off. If you are new to JigSoft, it 
is a good idea to leave this on until you become familiar with the program. Once you know your way around JigSoft, you 
can disable this option

Scatter
This option will scatter any unsolved puzzle pieces away from the inside of the puzzle frame in the Main Area (where your 
puzzle is completed).
This option is especially helpful at the beginning of a puzzle session to clear out the inside of the frame so you can place 
pieces in it without getting distracted. It is also handy to uncover pieces that may have been covered up by other pieces.
There are two settings for the scatter option which can be changed in the Preferences dialog (under the Options menu): 
normal scatter and wide scatter.
Normal Scatter: Scatters pieces to the areas closely surrounding the Main Area. Pieces will tend to pile up on one another
and overlap.
Wide Scatter: Scatters pieces throughout the entire puzzle desktop. This option is helpful if you don’t want as many pieces
to pile up on top of each other during a scatter. However, this mode will require you to scroll around the screen more often
in search of pieces.
This option is equivalent to clicking the scatter icon on the tool palette.

Zoom
This option will put JigSoft into Zoom mode. The cursor will change to a magnifying glass. Position the cursor (the center 
of the plus sign (+) is the hot spot) over the spot you want to magnify, and click the left mouse button. The spot you clicked
will be positioned in the middle of the screen. You can continue to zoom in by repeatedly clicking the left mouse button, or 
zoom out by clicking the right mouse button.
When you’re done looking at a piece in detail, choose this option again or click the zoom icon to return to normal view. 
Your cursor will revert to an arrow. You cannot assemble or finish the puzzle in zoom mode.
This option is equivalent to clicking the zoom icon on the tool palette.

Note: When zooming in, it is possible that the colors on the pieces you’re magnifying will change. 
This is an effect of zooming in too far on a bitmap.

Main Puzzle Area
This option positions the puzzle desktop view to the Main Area. The Main Puzzle Area is the upper left portion of the 
puzzle desktop, where the final assembly of the puzzle must be done.
You can also use the Quick Scroll icon on the tool palette to switch between the different areas.

Note: If the “Hide Work Areas” option of the Preferences dialog has been enabled, Work Areas 1 and 
2 will not appear on the puzzle desktop.

Work Area 1
This option positions the puzzle desktop view to Work Area 1. Work Area 1 is the upper right portion of the puzzle desktop.
This area is the first of two work areas provided to assemble parts of the puzzle away from the Main Area.
You can also use the Quick Scroll icon on the tool palette to switch between the different areas.



Note: If the “Hide Work Areas” option of the Preferences dialog has been enabled, Work Areas 1 and 
2 will not appear on the puzzle desktop.

Work Area 2
This option positions the puzzle desktop view to Work Area 2. Work Area 2 is the lower left portion of the puzzle desktop. 
This area is the second of two work areas provided to assemble parts of the puzzle away from the Main Area.
You can also use the Quick Scroll icon on the tool palette to switch between the different areas.

Note: If the “Hide Work Areas” option of the Preferences dialog has been enabled, Work Areas 1 and 
2 will not appear on the puzzle desktop.

Puzzle Overview
This option positions the puzzle desktop view to the Overview window. This area displays an overview of the puzzle, if the 
Overview Window option (under the View menu) is enabled. 
The Overview window is initially set at the lower right portion of the puzzle desktop. If this option is disabled, then the 
Overview area will be blank. If you have positioned the Overview window in an area other than the lower right portion of 
the desktop, this option will not display the Overview window.
You can also use the Quick Scroll icon on the tool palette to switch between the different areas.

The Organize Menu
This menu allows you to quickly switch between JigSoft’s four organizational modes, which are designed to help you 
move and manage pieces between the three separate work areas available on the JigSoft desktop. 
The work areas feature can help you organize different types of pieces quickly into different areas, much like you would if 
you were putting a jigsaw puzzle together on a tabletop.

Regular Mode
This option sets the organize mode to Regular Mode. This mode lets you drag pieces anywhere on the desktop. This is 
the mode you must be in to actually connect pieces together and complete the puzzle. When you choose this option, the 
cursor will change to an arrow.
This option is equivalent to clicking the upper left portion of the organize icon on the tool palette.

Organize to Work Area 1
This option sets the organize mode to Organize to Work Area 1. This mode lets you send pieces to Work Area 1, the first 
of two special work areas available to you. When you choose this option, the cursor will change to a “1.” When you click a 
piece in this mode, it will automatically be moved into Work Area 1.
This option is equivalent to clicking the upper right portion of the organize icon on the tool palette.

Organize to Work Area 2
Sets the organize mode to Organize to Work Area 2. This mode lets you send pieces to Work Area 2, the second of two 
special work areas available to you. When you choose this option, the cursor will change to a “2.”
This option is equivalent to clicking the lower left portion of the                    organize icon on the tool palette.

Organize Back to Main Area
Sets the organize mode to “Organize back to Main Area.” This mode lets you send pieces from anywhere on the screen–
including any pieces in the two work areas–back into the Main Area. When you click this portion of the organize icon, the 
cursor will change to an “M.” Puzzle pieces moved from one of the work areas will appear in the same relative position in 
the Main Area.
This option is equivalent to clicking the lower right portion of the organize icon on the tool palette.

The Options Menu

Customize Skill Levels Ctrl+X

This option will bring up a dialog that allows you to specify settings for each skill level. You can change the pixel snap 
(automatically snaps a puzzle piece into place if you drag it within a specified number of pixels of its correct location), 



whether or not the pieces are randomly flipped upside down (mirror image), and the number of pieces that define each 
skill level. The User Carved option within this dialog does not allow you to specify the number of pieces because this is 
defined when you actually create the cut.

Preferences Ctrl+Y

The Preferences dialog allows you to change the behavior of many of JigSoft’s features. These features include: random 
seed value, multi–piece drag options, scatter options, overview options, scroll bars, sound, and the work areas.

Random Seed Value
A random seed value of zero (0) tells JigSoft to create a new puzzle cut for each different puzzle session. This means that
you will very rarely, if ever, get an identical puzzle to put together. JigSoft can generate 32000 different puzzle cuts. You 
can also generate custom puzzle cuts by using the User Carved option (under the Skill menu).
A value between 2 and 32000 tells JigSoft you want it to generate a particular puzzle cut for each puzzle session. Each 
puzzle cut has a number associated with it. For example, set this option to any number between 2 and 32000. If you like 
the puzzle cut generated, make a note of that number. You can then set this option to that number each time you want to 
repeat that particular puzzle cut. This option is useful if you are having a timed competition with other people and want to 
make sure each person gets the same puzzle cut to work on.

Note: Do not set this option to 1—unpredicatable results may occur.

Multi–Piece Drag Option
This option tells JigSoft how you want it to drag pieces that have been connected together outside the puzzle frame. In 
general, the greater the number of connected pieces, the slower it will be to drag them. Therefore, when you’ve connected
many pieces together, dragging those connected pieces can get very slow, especially on slower computers. To make 
moving connected pieces faster, JigSoft provides the option of moving connected pieces by dragging in “Complete 
Bitmap” mode or by pointing and clicking in “Cursor Only” mode. In “Cursor Only” mode, you move a connected piece by 
clicking it once with the left mouse button, moving the cursor to the location to which you want the piece to be moved, and
clicking the left mouse button again.
Before using this option, we suggest that you use the Organize back to Main Area icon (on the tool bar) or the Organize 
back to Main Area option (under the Organize menu) to move connected pieces back to the Main Area.

Scatter Option
The scatter option offers choices between the two modes available to scatter any unsolved puzzle pieces away from the 
inside of the puzzle frame in the Main Area (where your puzzle is completed).
The    two settings for the scatter option are: normal scatter and wide scatter.
Normal Scatter: Scatters pieces to the areas closely surrounding the Main Area. Pieces will tend to pile up on one another
and overlap.
Wide Scatter: Scatters pieces throughout the entire puzzle desktop. This option is helpful if you don’t want as many pieces
to pile up on top of each other during a scatter. However, this setting will require you to scroll around the screen more 
often in search of pieces.

Overview Option
The Overview window shows an overview of what the completed puzzle should look like. This is similar to looking at the 
box top of an ordinary jigsaw puzzle. This area will be blank if the Overview Window option (under the View menu) is 
disabled. There are two modes for the Overview window: standard placement and custom placement.
Standard Placement: The Overview window is initially located in the bottom right portion of the puzzle desktop. This 
position is called Standard Placement. You can get to this portion of the desktop quickly by using the Quick Scroll icon on 
the tool palette or the scroll bars. If this Overview Window option (under the View menu) is disabled, this area will be 
blank.
Custom Placement: In this mode, the Overview window will appear near the Main Area of the puzzle desktop in a 
sizeable, moveable window.

Note: You must size the window before you start a puzzle session. You should position the window 
before you start a puzzle session. Once a puzzle session has started, you can move the Overview 
window only while a puzzle session is “paused.”

Disable Fast Scroll Bars
This option will turn off JigSoft’s fast scroll bar feature. This feature allows you to click anywhere in the scroll bar to quickly
reposition the puzzle desktop view, instead of having to use the scroll bar arrows or drag the scroll thumb.



You’ll probably want to disable this feature if you find that you are accidentally clicking in the scroll bar region and 
inadvertently repositioning yourself within the puzzle desktop.

Disable Sound
This option will turn the sound features of JigSoft off. This means that you will not here a beep when pieces are connected
or fit into the puzzle frame.

Hide Work Areas
This option allows you to disable the work areas and their associated functions. Instead of having work areas in the upper 
right and lower left portions of the puzzle desktop, you will have blank space which you can use to scatter pieces around.

Note: If you hide the work areas, the Quick Scroll icon will not take you to Work Areas 1 and 2. The 
organize modes will be also disabled since there are no work areas to organize.

Colors

This option allows you to select colors for the puzzle desktop. To change colors, click the diamond next to the color you 
want.
Exterior: This refers to any area outside the Main Area and work areas.
Interior: This refers to the areas inside the Main Area and work areas.

Note: You can also change colors by using your mouse. To change the exterior color hold down the 
Shift Key and click the left button. To change the interior color hold down the Shift Key and use the 
right button. Each time you click it will change the color as you cycle through the color palette.

Overview Size

This option will bring up a special dialog box that will allow you to customize the height of the Overview window. The 
default is 300 pixels (the maximum height available). The minimum height is 100 pixels. The width dimension will be 
adjusted for you automatically. You may specify a height by entering a number in the Overview Size box or by stretching 
and shrinking the rectangle in the dialog. The rectangle will appear in the same color as the work areas.

Save Settings
This option saves the values you have set in the Customize Skill Levels and Preferences dialogs.



Appendix A–Glossary
Flipped
This term refers to the state of a puzzle piece that is a mirror image of itself. This is not the same as rotating 180 degrees. 
This option was created to enhance the difficulty of solving a puzzle and is not meant to be an exact representation of 
turning an actual puzzle piece. You can flip a puzzle piece by clicking the right mouse button. Puzzle pieces must be 
flipped to their correct orientation before they can be connected to other pieces or placed in the Main Area.

Overview Window
This term refers to a special window that contains a complete picture of the puzzle you’re working on. Depending on the 
type of Overview you have selected, this window may be sizeable as well as moveable. The Overview Window can be 
repositioned only before you start a puzzle session or while a puzzle session is in “Pause” mode.

Pixel Snap
You can make assembling pieces easier or harder by adjusting the pixel snap, in the Customize Skill Levels dialog (under 
the Options menu). Pixel snap automatically snaps a puzzle piece into place if you drag it within a specified number of 
pixels of its correct location. You can specify even numbered values ranging from 2 to 10. The higher the setting, the 
easier it is to put the puzzle together.
If you’re working in the Main Area, pixel snap will “snap” pieces to their correct location. If you’re working with two or more 
pieces, a higher pixel snap setting will make it easier to put them together.

Puzzle Desktop
This term refers to the entire space available to you to assemble the puzzle. This includes the Main Areas, work areas, 
and the overview area.

Puzzle Frame
This term refers to the rectangle on your screen where you complete puzzles, create user–defined cuts, and initially view 
puzzle pictures.

Tool Palette
This term refers to the group of icons located in the floating palette with “Tools” in the title bar. The tool palette can be 
positioned anywhere by dragging its title bar. You can show or hide the tool palette by choosing Tool Bar (under the View 
menu).


